Mehr

Plugin PRISM konnte aufgrund eines Fehlers beim Aufrufen seiner classFactory()-Methode in QGIS1.8 inWin8 nicht geladen werden

Plugin PRISM konnte aufgrund eines Fehlers beim Aufrufen seiner classFactory()-Methode in QGIS1.8 inWin8 nicht geladen werden


Wenn ich ein Plugin in QGIS lade, traten einige Probleme auf:

Ich hatte versucht, die Dateien anderer Python27 in die Python 27-Datei von QGIS zu kopieren, aber es funktioniert immer noch nicht.


Plugin PRISM konnte aufgrund eines Fehlers beim Aufrufen seiner classFactory()-Methode nicht geladen werden

Traceback (letzter Aufruf zuletzt): Datei "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 164, in startPlugin plugins[packageName] = package.classFactory( iface) Datei "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/pluginsPRISM__init__.py", Zeile 25, in classFactory from prism import PRISM File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) Datei "C:/PROGRA~2/Quantum GIS Lisboa/apps /qgis/./python/pluginsPRISMprism.py", Zeile 15, in import numpy File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) Datei "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpy__init__.py", Zeile 137, in import add_newdocs File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, l evel) Datei "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpyadd_newdocs.py", Zeile 9, in from numpy.lib import add_newdoc Datei "C:/PROGRA~2 /Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) Datei "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpylib__init__.py", Zeile 4, in from type_check import * Datei "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgis utils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) Datei "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpylib ype_check.py", Zeile 8, in import numpy.core.numeric als _nx Datei "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) Datei "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpycore__init__.py", Zeile 5, in import Multiarray-Datei "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", Zeile 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: DLL load fehlgeschlagen: %1 O Ī Win32 ε{ C

Python 版本: 2.7.5 (Standard, 15. Mai 2013, 22:43:36) [MSC v.1500 32 Bit (Intel)]

QGIS-Version: 1.8.0-Lisboa Lisboa, 6416f38

Python 路徑: ['C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python', 'C:/Users/corbies/.qgis//python', 'C:/Users/corbies/.qgis //python/plugins', 'C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins', 'C:ProgrammeIntergraphERDAS IMAGINE 2014usrlibWin32Releasepython ', 'C:WINDOWSSYSTEM32python27.zip', 'C:PROGRA~2Quantum GIS LisboaappsPython27DLLs', 'C:PROGRA~2Quantum GIS LisboaappsPython27 lib', 'C:PROGRA~2Quantum GIS LisboaappsPython27libplat-win', 'C:PROGRA~2Quantum GIS LisboaappsPython27liblib-tk', ' C:PROGRA~2Quantum GIS Lisboaappsqgisin', 'C:PROGRA~2Quantum GIS LisboaappsPython27', 'C:PROGRA~2Quantum GIS LisboaappsPython27 libsite-packages', 'C:Programme (x86)ArcGISDesktop10.2in64', 'C:Programme (x86)ArcGISDesktop10.2arcpy', 'C: Programmdateien (x86)ArcGISDesktop10.2ArcToolboxScripts', 'C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packagesPIL', 'C:PROGRA~2 Quantum GIS LisboaappsPython27libsite-packag eswin32', 'C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packageswin32lib', 'C:PROGRA~2Quantum GIS LisboaappsPython27lib site-packagesPythonwin', 'C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packageswx-2.8-msw-unicode', 'C:PROGRA~2Quantum GIS Lisboa appsqgispythonpluginsfTools ools']

Ich denke, dass das für QGIS 1.8-1.99 entwickelte Plugin


Das Plugin befindet sich nicht im offiziellen Repository.

Sie müssen sicherstellen, dass es mit QGIS 1.8 funktioniert. Die meisten Plugins sind nur für die Ausführung mit QGIS 2.0 und höher ausgelegt.


Schau das Video: Windows 8 netcad kurulum videosu