Mehr

Problem beim Rastern

Problem beim Rastern


Ich versuche, ein Shapefile mit dem Werkzeug "Rasterisieren" in qgis zu rastern. Das Problem ist, dass das resultierende Raster nicht richtig gerastert zu werden scheint…


Die blaugrünen und violetten Linien zeigen den Wasserfluss, und dies ist das Shapefile, das ich rastern möchte

Das resultierende Raster nimmt die gesamte Ausdehnung der Datei und weist ihm den Wert 1 zu, auch wenn es nicht Teil des Wasserflusses ist

Dialog


Angenommen, Ihre Projektion ist in Metern angegeben, umfasst das Verfahren zum Rastern:

1) Kopieren Sie in den Ebeneneigenschaften die Ausdehnung Ihres 'Flüsse'-Shapefiles und entfernen Sie die Textzeichen. In meinem Beispiel ist:

168902.13 85311.7 831499.38 1271303.48

2) Klicken Sie rein Raster -> Konvertierung -> Rasterisieren Menüoption. Wählen Sie den Namen der Ausgabedatei aus und klicken Sie anschließend auf "Rasterauflösung in Karteneinheiten pro Pixel". Ich gehe von einer Pixelgröße von x = 30 m, y = 30 m aus. Klicken Sie nun auf das Bleistiftsymbol und fügen Sie das gdal_rasterize Befehl, vor Pixelgröße, Ihr Äquivalent dazu:

-te 168902.13 85311.7 831499.38 1271303.48

Der vollständige Befehl wäre in meinem Fall:

gdal_rasterize -a id -te 168902.13 85311.7 831499.38 1271303.48 -tr 30.0 30.0 -l rios_utm19prj /home/zeito/Desktop/UTM_19_latlong/rios_utm19prj.shp /home/zeito/Desktop/UTM_19_laterlong./riifvers_rasterlong

3) Nachdem Sie auf OK geklickt haben, 'Zoom In' auf einen beliebigen Bereich des Ausgabe-Rasters (gerastert nach ID und mit Pseudocolor-Renderer), wo beobachtet werden kann, dass die Rasterung wie erwartet ist:


Schau das Video: Problemer med Adlerauge?